Materi Pembelajaran Borland Delphi

PEMROGRAMAN BASIS DATA (DATABASE PROGRAMING)

Basis Data adalah kumpulan dari beberapa tabel yang saling berelasi dan berhubungan satu sama
lain sehingga dapat memberikan suatu data/informasi. Berbagai jenis database yang dapat di olah
dengan Delphi, misalnya : Paradox, dBase, MS-Access, ODBC, SyBase, Oracle dan lain-lain.

Untuk pembahasan database paradox 7 dengan menggunakan Database Desktop.

DATABASE DEKSTOP

Database desktop merupakan aplikasi yang terdapat pada Borland Delphi yang dapat digunakan
untuk mengimplementasikan rancangan tabel dalam basis data yang kaitannya dengan aplikasi
yang akan dibuat. Secara default database yang digunakan dalam aplikasi database deskstop adlah
paradox. Ekstensi tabel untuk paradox adalah *.db. untuk membukanya pilih Start > Program >

Borland Delphi 6 > Database Desktop. Maka akan muncul tampilan sebagai berikut :

MEMBUAT TABEL

Adapun langkah-langkah membuat tabel adalah :
1. Pilih menu File > New > Table

2. Pilinh Paradox 7

3. Pilih OK

&2 Database Desktop
FEN Edit Tools Window Help

QBE Query...
Open » SiQL File
Closs
Save
Save Hs,..,

Create Table

Table bype:

warking Directory. ..
Private Direckory. ..

Exik

4. Buatlah rancangan tabel sebagai berikut :

No Field Name Type | Size | Key
1 | NIS A 5 *
2 | Nama A 30
3 | Sex L
4 | Alamat A 50
5 | Agama A 15
6 | Kd_Kelas A 2
7 | Hobi A 15

Ket : * adalah primary key.
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5. Pilih Save As, beri nama file Siswa.db kemudian tekan tombol Save.

Create Paradox / Table: { Untitled ) El Save Table As
Field rogter: Table properties: Sevolis |L’:) Program SMAN3 ﬂ & IfF '
| Field Narme |Type| Size |Key alidity Chiecks -
1 HIS A 50
2 Mama A 30 Q
3 Sex L I~ 1. Required Field
4 Alamat A 50 2 U -
5 Agama A 15 £ MINImum valie:
6 Kd_Kelas A 2
7 A 148 2 Maximum value:
4. Default value File name: |Siswa
: * - C |
Enter a field name up to 25 chaiacters long, ‘ & Picture: SaREn |Paladox [".db] J ﬁ
oo I -
Azsist,..
Q Options: [ Display table
Save fs | Cancel | Help | r

MEMBUAT ALIAS MANAGER

Alias manager berguna untuk memudahkan kita dalam menentukan letak suatu database atau
sejumlah tabel-tabel yang sudah ada. Dengan adanya alias manager maka tabel-tabel tersebut
dapat dikelompokkan menjadi satu tempat.

Adapun langkah-langkah membuat alias manager adalah :

1. Pilih menu Tools - Alias Manager

&~ Database Deskiop
File Edit BEEEN Window  Help

! Alias Manager. ..

LIkilities k
Passwords, .,

2. Pilih New kemudian Isilah nama database alias (misalnya SMA3).

Alias Manager E'
W Public aliaz Defining new database aliaz. Enter
changes and choose Keep Hew
Databaze alias |SM.-'1'-.31 j when done.
Drriver bype: |STﬂNDﬂHD ﬂ

Path: |C:\Program Files\Cornm £ Show public aliases anly
" Show project aliazes anly

* Show all aliazes

Browsze. .

Ok

Feep Hew
Cancel
Bemove

| Help

i

3. Pilih Browse kemudian pilihlah letak/directory yang akan kita gunakan untuk menyimpan

alias manager tersebut (misalnya D:\Program Siswa ). Kemudian tekan tombol OK.
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Directory Browsern E'

Directories:

|D:"-.F'n:ug|ram Sizva ok

—D:

— 000
S Aplikasis PM = Cancel
—DATA BTEL -
O DATA MINE
| IGAMES Help

O MASTER -
—MODUL SMA3Z FL
HOM5S0Cache

R ecycled

— I RILEXS

5 pstem Yolume Ir

—OTITIP BENTAR
L wfienda —

|

Dirive [or Aliag):
|E=0:\Program Siswa =1

4. Pilih Tombol OK kemudian pilh tombol Yes.

Public Aliases Have Changed

Yes ko Cancel

5. Nah sekarang database alias sudah terbuat. Ingat namanya adalah SMA3.

MEMBUKA TABEL MELALUI ALIAS MANAGER

Dengan adanya Alias manager kita dengan sangat mudah membuka atau mengakses suatu tabel
yang telah kita buat.

Adapun langkah-langkah membuka tabel dengan alias manager adalah :

1. Pilih menu File = Open - Table

&2, Database Desktop

§-N Edit Tools ‘Window Help
Mlew 3
5y

0L Flle...

Working Direckary,.,
Private Directory..,

Eat

2. Pilih combobox Alias : SMA3, kemudian pilih nama tabel yang akan kita buka (misalnya tabel

kita tadi : Siswa.db). Lalu pilih tombol Open.
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Open Table _
Laak ir: IE} Program Sizwa ;I = £k E-

Sisinta

File narme: I Open I
Files of type: | Tables [*.db:".dbf) | Cancel |

Alias: [=5Maz: =] Help |
=woRk: ~
EDEDEMOS: i
= DefaultDD:
= IBLacal

FRIW:

1

(€

MENGUBAH FIELD TABEL (RESTRUCTURE)
Adapun langkah-langkah membuat tabel adalah :
1. Pilih menu Tool - Utilities > Restructure

2. Pilih Letak tabel yang akan di ubah.

Select File

&2 Database Deskiop

Lock in: [ 59 Program SMAN3 -l e et B
File Edit [ -
Slswa
flias Manager. .,
Add...
Passwords.,.. Copy...
Delete. .,
Empby... File name: | lﬂl
Info Skructure, .. Files of type: | Tables (% db:” obi] ~l Cancsl |
Rename... liss: [=smanz: | Hep |
]
v

3. Pilih Open.
Maka akan muncul kembali struktur tabel yang telah kita susun semula. Nah sekarang silakan

anda dapat merubah field tabel tersebut lalu tekan tombol Save.

Restructure Paradox 7 Table: siswa.db

Field rozter: T able properties:
Field Mame Type| Size |Key | walidity Checks |
1| MEN— - 3| = Define.. |
2{Mama A 30
3| Sex L ™ 1. Required Field
4| Alamat A Al 2 [ e
5| Agarna - 15 2 Minimum walue:
B Kd_Kelas A 2 |
7| Hobi £ 15 3. Maximum value:
4. Drefault walue:
Enter a field name up to 25 characters long. 5. Picture:
[~ Pack Table Agzist . |
Save I Save fiz | Cancel | Help
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MEMBUKA DAN MENGISI DATA TABEL
Adapun langkah-langkah membuat tabel adalah :
1. Pilih menu File > Open

7. Database Desktop
GIEN Edit Tools ‘Window Help

Mew 3
Qs Query..

6L File...

Warking Directory, .,
Private Direckory, ..

Exit

2. Pilin Letak tabel yang akan diisi (nama tabel : Siswa.db). Lalu pilih Open.

Lok in: | £ Program SMAN3 ~| = = B
@ Siswa
File name: | Tpen |
Files of lwpe: |Tah|es [*.db;*.dbf] j Cancel
Alias: EEEE =] Help |
E=DEDEMOS: ~

E=DefaultDD:
B IBLocal:
=PRI

=]

3. Maka akan muncul form seperti dibawah ini .

i Database Desktop
File Edit ‘Wiew Table Record Tools ‘Window Help

XEla B

& Tahle : C:\...\siswa.dh

||« v || n] falt]|

|Kd_Kelas

4. Untuk mengisi data pada tabel tersebut pilih menu Table > Edit Data atau tekan F9 pada
keyboard.

5. Sekarang coba isilah data acak (sembarang) sebanyak 5 buah.
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&2 Database Desktop
File Edit Wew Table Record Tools ‘Window Help

K|%(d| 2l

B8 Table : C:\.. . \siswa.db

|1|«|1|b|»|bl| & |

Nama Alamat Agama kd Kelas Hobi
__ 1100007 | Mink True | JL LA Adisucipta Ma 21 EET 01 Membaca
200002 | Dian True  |JI Kaliurang Km. 55 Mo 454, Islam 0z Melukis
3| 00003 | Larasati Falsze |JI. Magelang Km. B Mo 23 Kristen 01 Olah raga
400004 | Yanto True  [JI Pramuka Gg. Bimo Mo 10 Budha 03 Monton
500005 | Dewi False |JI. Janti Blak O Mao. 81 Hindu 03 Memasak
6/ I
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KOMPONEN DELPHI UNTUK DATABASE
Untuk membuat suatu program aplikasi dengan menggunakan database pada Delphi ada
beberapa komponen secara visual dan non-visual yang sudah tersedia pada Delphi. Pada

Delphi komponen yang digunakan untuk database secara umum dikelompokkan menjadi 3

page yang terdapat pada Component Palette yaitu :

1. Page Data Access
2. Page Data Controls
3. Page BDE

Komponen pada Page Data Access

Standard] ﬁ\dditiunal] WinEE] System  DataAecess l Data Ennlrnls] dhE:-:nress] DataSnan] BOE ] 400 ] IntEIEase] WebServices |

AR

Pl * -I
" "
e AML RIS Ra

Fo) EHL wEML

J

Nama Komponen

Fungsi Komponen

TDataSource

Untuk menguhubungkan antara data access component dengan

data aware visual control.

Komponen pada Page Data Controls

Slandard] f-‘u:lditiunal] Win32| SUSlem\ Datadceess Data Controls ||:||:|E:-:nress] DataSnan] BOE \ A00 ] InterEase\ Wehﬁewices]

P DmAm dLg8 % 0addde

Nama Komponen

Fungsi Komponen

TDBGrid

Untuk menampilkan data dan edit dataset dengan format tabular.

TDBNavigator Kontrol posisi record seperti Previous, Next, First, Last. Selain itu
juga mengubah status dataset seperti open, close, edit, post,
delete, cancel, edit.

TDBText Menampilkan sebuah field sebuah tabel

TDBEdit Menampilkan dan mengedit sebuah field dalam edit box

TDBMemo Menampilkan dan mengedit sebuah field pada text editor

TDBImage Menampilkan dan mengedit field image (gambar)

TDBListBox Menampilkan pilihan untuk mengisi sebuah field

TDBComboBox Menampillkan sebuah edit box dan drop list untuk mengisi sebuah
field.

TDBCheckBox Menampilkan check box untuk sebuah field Boolean

TDBRadioGroup Menampilkan sejumlah pilihan dalam bentuk radio button.
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Komponen pada Page BDE

Standard]ﬁddilinnal]WinEE] Sustem\ Dataﬂccess] Data Enntrnls] dl:iE:-:nress] DataSnan BOE ‘ﬁDD \InterEase]WehSewines]

. EERO8EER

Nama Komponen

Fungsi Komponen

TTable

Sebagai datasource yang mengakses record dari tabel

TQuery

Untuk mengakses record dari tabel dengan menjalankan perintah

SQL (Structure Query Language).
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STRUCTURED QUERY LANGUAGE (SQL)

Adalah bahasa standar yang digunakan untuk memanipulasi basis data relasional. Pada
mulanya SQL diciptakan IBM untuk system manajemen basis data relasional (RDBMS) milik
mereka yaitu DB2. Dalam perkembangannya, SQL kemudian digunakan juga pada produk-produk
RDBMS dari perusahaan lain seperti ORACLE, Informix, Ms SQL Server, Sybase, dan Interbase.
Akhirnya ANSI yaitu badan standarisasi dari Amerika merilis standar SQL yang sering disebut
ANSI SQL. Hingga saat ini bagi seorang programmer database, SQL merupakan bahasa
pemrograman yang tidak asing lagi.

Dalam bahasa SQL terdapat 4 bagian utama yaitu SELECT, INSERT, UPDATE dan DELETE.
Dimana ke empat bagian utama perintah tersebut dapat dikombinasikan untuk memanipulasi

suatu basis data.

PERINTAH SELECT
Perintah select berguna untuk menampilkan isi tabel pada suatu database. Adapun format

penulisan perintah Select adalah :

SELECT [DISTINCT] kolum
FROM nama_tabel
[WHERE kondisi_pencarian]
[ORDER BY pengurutan]
[GROUP BY group_list]
[HAVING having_condition]

Praktek :
1. Pilih Start
2. Pilih Borland Delphi 6

3. Pilih SQL Explorer, maka akan muncul tampilan seperti dibawah ini.

= SOl Exploren
Object Dictionary Edit  Yew Options Help

== el - oot = o
all D atabase Aliases Drefinition of Sk

D atabazes l Diu:tiu:unar_l,l] Drefinition l Erter SQL]

- % Databases Type STAMDARD
+-"g dBASE Files PATH D:%Program Siswa

5% DEDEMOS

2% DefaultDD

@ Ewcel Files

2% IELocal

MS Access Database

% ElE

"5 Triokators

+ -] [ [ [ [ [

1 items in 3MA3,

Pada tab Databases, pilih SMA3
Pilih tabel siswa.db
Pilih Enter SQL pada form disebelah kanan.
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7. Kemudian baru kita ketik perintah SQLnya lalu pilih tombol Execute Query
a. SELECT * FROM siswa

& 5oL Explorer

Object  Dictionary Edit  Wiew Options Help
= — - e
All Database Aliazes Execute SOL queries in databaze SMA3
Databases ] Diclinnary] Definilic\n] Data Enter SHL ]
- Databases SELECT * FROM siswa &3
+-"g dBASE Files
+ -84 DBDEMOS
+ ::é Defaultl_:)D —
+-"§ EwxcelFiles
+ gé |BLocal HIS Mama |Se:-¢ |A|amal Agama k.d_Kelaz|Hobi -~
+-g MS Access Database Mink True [JIL LA Adisucipto Mo 21 Islam 01 Membaca
= E Q0002 Dvian True  JI Kalivriang Em. 5.5 Ho 454 | 1slam oz Melukis
siswa db 00003 Larazati Falze  JI Magelang Km. & Mo 23 Frizten o Olahk raga
Fi‘elds 0004 vanta True | JI Pramuka Gg. Bima Mo 10 | Budha oz Monton
|ndices 00005 Drewi Falze JI Janti Blok O Mo, 81 Hitidu 03 temaszak.
*Walidity Checks
Referential Constraints
Security Specs
+ Farnily M ernbers
+-"g& Triokotors
v
< > < >
O rows were affected

b. SELECT * FROM siswa WHERE nama="Mink*

= sqL Explorer

Ohject Dictionary Edit  Wiew Options  Help
= — L |
All Database Aliases Execute SOL gueries in database Sh443
Databases l Dictionary ] D efinition I Data Enter SQOL l
=5 Databazes SELECT * FROM siswa F
+-"& dBASE Files WHERE nama='Mink'
+ B& DEDEMOS B
+ ié Defaultl_:)D g
+-"gg Ewcel Files
+-88 IBLocal |NIS |Nama |Sex |.-’-‘«Iamat
+-"g MS Access Database ﬂuuum Mink. True |JI LA Adisucipto Na 21
=
sigwa.db
Figlds
Indices
Walidity Checks
Feferential Constraints
Security Specs
Family Members
+-"& Triokotors
< > < >
0 rows were affected

Cc. SELECT * FROM siswa ORDER BY hobi

= sqL Explorer

Object  Dickionary Edit  Wiew Options Help
= — [
All Database Aliases Execute SOL queries in database SMA3Z
Databases l Dictionar_l,l] Drefinition I Data Enter SOL ]
—1-Em Databazes SELECT * FROM siswa Z
+-"g5 dBASE Files ORDER EY hobi
+-5& DBDEMOS | N
+ iéﬂ Defaultl_:JD g
+-"& Ewxcel Files
+- 8% |BLocal MIS |Nama |Sex |Alamat Agama | kd Kelaz|Hobi -~
+ 7§ MS dccess Database »|00002| Dian True | JI. Kaliurang K. 5.5 No 454 | Islam 0z Melukis
= Shias || 00005 Devi False |JI. Jarki Blok O Ma. 51 Hindu |03 Memasak
= Tables = 00007 | Mink True |l L& Adisucipta No 21 lslam | 01 Membaca
[—| EIFWA. 1
Ficlds n 00004 vanta True | JI. Pramuka Gg BimoMo 10 Budha 03 Manton
Indices n 00003 Laraszati Falze JI. Magelang K. 6 Nao 23 Eristen 01 Olah raga
“Walidity Checks
+ Fieferential Constraints
+ Security Specs
+ F amily Members
+-"g Triokotors
-
< > < >
0 rows were affected

d. insert into siswa(NIS,Nama,Sex,Alamat,Agama,Kd Kelas,Hobi) VALUES (°0006",

"Airin®,"False”,"Jl_Sostrowijayan®, " Islam®,"01", "Membaca*"); atau bisa
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menggunakan perintah insert iInto siswa values ("00006","Airin","False”,

*Jl._Sostrowijayan®, "lIslam®,"01","Membaca®);

= SOL Explorer

Object  Dictionary Edit  Wiew Options Help
= =1 -
Al D atabaze Aliases Execute SOL queries in database SkAZ
Databaszes ] Dictionary] Definition] Data Ernter SOL l
=M Databazes INSERT INTO siswa(HNIS,Nama,Sex,ilawmar,igowa,HKd Helas, Hobil A £Z
+ &g dBASE Files VALTES ('0006','Adirin', 'False',K 'Jl.Sostrowijayan', Islam',
+ 5% DBDEMOS ‘01, ‘Membaca') L
4 24 DefaultDD —
+- & Ewxcel Files
+- 88 |ELocal MHIS |Nama |Se:-c |.-’-\Iamat -~
+-"§ MS Access Database »| 00001 | Mink True | JI L& Adisucipts Mo 21
= ShAg | |oo002| Dian True |JI Kaliurang K. 5.5 Mo 452
= Tables || ooo0z| Larasati False JI. Magelang Km. 6§ Mo 23
B 00004 | vanto True | JI. Pramuka Gg. Bima Mo 10
Indices : 00005 | Dewi False | JI. Janti Blok O Mo, &1
Walidity Checks || 00006 | Airin Falze | Jl.Sostrowijagan
+
E3
+ Family Members
+ & Triokotors
P
< > < >
0 roves were affected

e. UPDATE siswa SET Kd_Kelas="02",Hobi="Maen Bola® WHERE NIS="00001"

= soL Explorer

Object  Dictionary Edit  Wiew Options Help
= ] =1 -
All D atabasze Aliases Execute SOL queries in database SkA3
Databases l Drictionary I D efinition ] Data  Enter SOL
= Databases UPDATE siswa SET Hd Helas='02' ,Hobi='Maen Bola' - .g
+-"g dBASE Files WHERE NIZ='00001'
+ 5% DBDEMOS = b
+- B8 DefaultDD g
+-"g& Ewxcel Files
+- 5% |BLocal MIS MNama |Sex |Alamat |Agama |Kd_KeIas Hobi -~
+-"§ MS Access Database Mink. True | JI L& Adisucipto Mo 21 Islam |02 Maen Bola
= SAg 00002 Dian | True JI Kaliorang Km. 5.5 No 454 |lslam | 02 Melukis
= Table..s db 00003 Larasati  False |JI. Magelang Em. 6 Mo 23 Kristen 01 Olah raga
=] 1I=Wa.
X 00004 anta True |JI. Prarmuka Ga. Bimo Mo 10 Budha (03 Monton
+ Fields
Indices 00005 Devi Falze |l Janti Blok O Mo, 81 Hindu 03 temaszak
Walidity Checks Q000 Airir Falze |JI.Sostrowijapan lglam 01 Membaca
+ Feferential Constraints
+ Security Specs
+ Family tembers
+-"& Triokotors
< ? e
0 rows were affected

f. DELETE FROM siswa WHERE Nama="Dian*

SOL Explorer

Object  Dictionary Edit Wiew Options  Help
= - L 2
All Databaze Aliases Execute SOL quenies in database SMA3
Databases ] Dictionary Definilion] Data  Enter SOL
--E® Databases DELETE FROM sizwa Al Z
+-"g dBASE Files WHERE HNama='Dian'
+-8& DEDEMOS - S
+-B8 DefaultDD =
+-"g Excel Files
+-54 1BLocal Mg [Mama  [sex [slamat |gama |Kd_Kelas| Hobi »
+-“f M8 Access Database P|00001 Mink. True I LA AdisuciptaMa 21 [lslam |02 Maen Bala
= SMA3 _DDDDS Larazati | Falze |l Magelangkm Mo 23 Kristen 01 Olah raga
= [ Tables & 00004 ¥anto | True \JI. Pramuka Gg. Bimo Mo 10 |Budha |03 Martan
= sizwa, —
. Q0005 Devi Falze |JI. Jarti Blak O Mo, 81 Hindu 03 Memazak
+ Fieldz — = B
Indices _DUDDE Airin Falze JI.Sostrowijayan lglam |01 tMembaca
Y alidity Checks
+ Referential Constraints
+ Security Specs
+ Family Members
+-"g Triokotors
< > i
0 rows were affected
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APLIKASI BASIS DATA DENGAN DELPHI 1

1. Buatlah rancangan form seperti berikut ini .

I | Form Data Siswa

[oBEMET |

- Nama: : [DBEdi2

- Sex: : |DBEd3

- Alamat - [DBEdH

PROPERTIES NILAI
KOMPONEN

Form Caption Form Data Siswa

Tabell DatabaseName SMA3
TableName Siswa.db
Active True

DataSourcel DataSet Tablel

Labell Caption NIS

Label2 Caption Nama

Label3 Caption Sex

Label4 Caption Alamat

Label5 Caption Agama

Label6 Caption Kd_Kelas

Label7 Caption Hobi

DBEdit1 DataSource DataSourcel
Data Field NIS

DBEdit2 DataSource DataSourcel
Data Field Nama

DBEdit3 DataSource DataSourcel
Data Field Sex

DBEdit4 DataSource DataSourcel
Data Field Alamat

DBEdit5 DataSource DataSourcel
Data Field Agama

DBEdit6 DataSource DataSourcel
Data Field Kd_Kelas

DBEdit7 DataSource DataSourcel
Data Field Hobi

DBNavigator DataSource DataSourcel

2. Jalankan program dengan menekan tombol F9 pada keyboard.
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4" Form Data Siswa g@
DATA SISWA SMA NEGERI 3 YOGYAKARTA TAHUN 2006 <h
NIS oooo [Sex [lamat -~
- True | JI L& adisucipto Mo

bdirk.
Nama | True | JI. Kaliurang Km. 5.51
Sex True | |ooooz| BLaBrasat Falze |JI. Magelang Km. 6 M
Alamat |JI. L.& Adisucipto Mo 21 . 00004 Yanto True | JIL Pramuka Gg. Bimo

I=lam st
Agama | < >
Kd_Kelas|®2
Hobi  |Meensos I S I I R )

APLIKASI BASIS DATA DENGAN DELPHI 2

1. Buatlah rancangan form seperti berikut ini .

I Fonm Data Megana

M arme

Capital

Continent

co | | Argentina

Buenos Aires

South &merica

| |Bolivia La Pa=z Sauth Armerica
|| Braail Eraszilia South America
_|Canada Ottavea Morth America
. tamBAH | wapUS | Epir | TUTUP
KOMPONEN PROPERTIES NILAI
Form Caption Form Data Negara
Tabell DatabaseName DBDEMOS
TableName Country.db
Active True
DataSourcel DataSet Tablel
DBNavigator DataSource DataSourcel
¥ Form Input Data
KOMPONEN PROPERTIES NILAI
Form Caption Form Input Data
Labell Caption Nama Negara
Label2 Caption Ibukota
Label3 Caption Benua
Label4 Caption Luas Daerah
Label5 Caption Jml Penduduk
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Editl Text {dikosongkan}
Edit2 Text {dikosongkan}
Edit3 Text {dikosongkan}
Edit4 Text {dikosongkan}
Edit5 Text {dikosongkan}
Buttonl Caption OK

Button2 Caption CANCEL

2. Double klik pada buttonl

Ketikkan kode program sebagai berikut :
form2:=TForm2_Create(SelT);

with form2 do

begin
Editl.Text:="";
Edit2.Text:="";
Edit3.Text:="";
Edit4.Text:="";
Caption:= "Menambah Data“”;
ActiveControl:=Editl;

end;

Form2.ShowModal ;

iT (Form2_ModalResult = mrOK) then

with Tablel, form2 do

begin
Append;
FieldByName("NAME®) _AsString:=Editl._Text;
FieldByName("CAPITAL") .AsString:=Edit2._Text;
FieldByName ("CONTINENT ") .AsString:=Edit3.Text;
FieldByName("AREA™) _AsString:=Edit4_Text;
FieldByName ("POPULATION®) _AsString:=Edit5._Text;

end;

form2.Free;

3. Double klik pada button2

Ketikkan kode program sebagai berikut :
var str:string;

begin
str = "Anda Yakin Negara® + Tablel_Fields[0]-AsString + "dihapus?;
iT (Application._messagebox(PChar(Str), "Peringatan”,
MB_YESNO or MB_ICONQUESTION) = IDYES) then
Tablel.delete;
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end;
4. Double klik pada button3
Ketikkan kode program sebagai berikut :
Form2:=TForm2.Create(Self);
with form2 do
begin
Editl_Text:=Tablel_Fields[0]-AsString;
Edit2_Text:=Tablel_Fields[1]-AsString;
Edit3.Text:=Tablel_Fields[2].-AsString;
Edit4_Text:=Tablel_Fields[3]-AsString;
Edit5.Text:=Tablel_Fields[4]-AsString;
Caption:="Mengedit Data“;
ActiveControl:=Editl;

end;

Form2.ShowModal ;

iT (Form2_ModalResult = mrOK) then

with Tablel, form2 do

begin
FieldByName("NAME®) _AsString:=Editl._Text;
FieldByName("CAPITAL") .AsString:=Edit2._Text;
FieldByName ("CONTINENT ") .AsString:=Edit3.Text;
FieldByName("AREA™) _AsString:=Edit4_Text;
FieldByName ("POPULATION®) _AsString:=Edit5._Text;
Post;

end;

form2.Free;
5. Double klik pada button3

Ketikkan kode program sebagai berikut :
Application.Terminate;
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